All vulnerabilities

Servers and applications

CVE-2025-57811

Craft is a platform for creating digital experiences. From versions 4.0.0-RC1 to 4.16.5 and 5.0.0-RC1 to 5.8.6, there is a potential remote code execution vulnerability via Twig SSTI (Server-Side Template Injection). This is a follow-up to CVE-2024-52293. This vulnerability has been patched in versions 4.16.6 and 5.8.7.

Severity
Medium 6.1
Published
25 Aug 2025
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Fixed in
4.16.6, 5.8.7
Sources
NVD

Affected software

SoftwareAffected versions
Craft CMSServers and applications · cpe:a:craftcms:craft_cms
  • Version 4.0.0-rc1
  • Version 4.0.0-rc2
  • Version 4.0.0-rc3
  • From 4.1.0 before 4.16.6
  • Version 5.0.0-rc1
  • From 5.1.0 before 5.8.7

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2025-57811
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2025-57811