All vulnerabilities

Servers and applications

CVE-2025-57758

Improper access control in the back end voters

Severity
Medium 4.3
Published
28 Aug 2025
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Fixed in
5.3.38, 5.6.1
Also known as
GHSA-7m47-r75r-cx8v
Sources
NVD, Project advisories (GitHub)

Description

Contao is an Open Source CMS. In versions starting from 5.0.0 and prior to 5.3.38 and 5.6.1, the table access voter in the back end doesn't check if a user is allowed to access the corresponding module. This issue has been patched in versions 5.3.38 and 5.6.1. A workaround involves not relying solely on the voter and additionally to check USER_CAN_ACCESS_MODULE.

Affected software

SoftwareAffected versions
ContaoServers and applications · cpe:a:contao:contao
  • From 5.3.0 before 5.3.38
  • From 5.4.0 before 5.6.1
ContaoServers and applications · github:contao/contao
  • From 5.0.0 before 5.3.38

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2025-57758
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2025-57758
  • GitHub Advisory Database https://github.com/advisories/GHSA-7m47-r75r-cx8v
  • github.com https://github.com/contao/contao/security/advisories/GHSA-7m47-r75r-cx8v