All vulnerabilities

Servers and applications

CVE-2025-49763

ESI plugin does not have the limit for maximum inclusion depth, and that allows excessive memory consumption if malicious instructions are inserted. Users can use a new setting for the plugin (--max-inclusion-depth) to limit it. This issue affects Apache Traffic Server: from 10.0.0 through 10.0.5, from 9.0.0 through 9.2.10. Users are recommended to upgrade to version 9.2.11 or 10.0.6, which…

Severity
High 7.5
Published
19 Jun 2025
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Fixed in
9.2.11, 10.0.6
Sources
NVD

Affected software

SoftwareAffected versions
Apache Traffic ServerServers and applications · cpe:a:apache:traffic_server
  • From 9.0.0 before 9.2.11
  • From 10.0.0 before 10.0.6

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2025-49763
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2025-49763