All vulnerabilities

Servers and applications

CVE-2025-46731

Craft is a content management system. Versions of Craft CMS on the 4.x branch prior to 4.14.13 and on the 5.x branch prior to 5.6.16 contains a potential remote code execution vulnerability via Twig SSTI. One must have administrator access and `ALLOW_ADMIN_CHANGES` must be enabled for this to work. Users should update to the patched versions 4.14.13 or 5.6.15 to mitigate the issue.

Severity
High 7.3
Published
5 May 2025
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Fixed in
4.14.13, 5.6.15
Sources
NVD

Affected software

SoftwareAffected versions
Craft CMSServers and applications · cpe:a:craftcms:craft_cms
  • Version 4.0.0-rc1
  • Version 4.0.0-rc2
  • Version 4.0.0-rc3
  • From 4.1.0 before 4.14.13
  • Version 5.0.0-rc1
  • From 5.1.0 before 5.6.15

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2025-46731
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2025-46731