Servers and applications
CVE-2025-46349
Unauthenticated reflected XSS in YesWiki <= 4.5.3
- Severity
- Medium 6.1
- Published
- 28 Apr 2025
- Last changed
- 17 Jun 2026
- Added to UpHeron
- 3 Nov 2026
- Fixed in
- 4.5.4
- Also known as
- GHSA-2f8p-qqx2-gwr2
- Sources
- NVD, Project advisories (GitHub)
Description
YesWiki is a wiki system written in PHP. Prior to version 4.5.4, YesWiki is vulnerable to reflected XSS in the file upload form. This vulnerability allows any malicious unauthenticated user to create a link that can be clicked on by the victim to perform arbitrary actions. This issue has been patched in version 4.5.4.
Affected software
| Software | Affected versions |
|---|---|
YesWikiServers and applications · cpe:a:yeswiki:yeswiki |
|
YesWikiServers and applications · github:yeswiki/yeswiki |
|
References
- NVD https://nvd.nist.gov/vuln/detail/CVE-2025-46349
- CVE.org https://www.cve.org/CVERecord?id=CVE-2025-46349
- GitHub Advisory Database https://github.com/advisories/GHSA-2f8p-qqx2-gwr2
- github.com https://github.com/YesWiki/yeswiki/security/advisories/GHSA-2f8p-qqx2-gwr2