All vulnerabilities

Servers and applications

CVE-2025-32432

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Starting from version 3.0.0-RC1 to before 3.9.15, 4.0.0-RC1 to before 4.14.15, and 5.0.0-RC1 to before 5.6.17, Craft is vulnerable to remote code execution. This is a high-impact, low-complexity attack vector. This issue has been patched in versions 3.9.15, 4.14.15, and 5.6.17, and is an…

Actively exploited: CISA added it to its Known Exploited Vulnerabilities catalog on 20 Mar 2026.

Severity
Critical 10.0
Published
25 Apr 2025
Last changed
24 Sept 2026
Added to UpHeron
1 Nov 2026
Fixed in
3.9.15, 4.14.15, 5.6.17
Sources
NVD

Affected software

SoftwareAffected versions
Craft CMSServers and applications · cpe:a:craftcms:craft_cms
  • From 3.0.0 before 3.9.15
  • From 4.0.0 before 4.14.15
  • From 5.0.0 before 5.6.17

Known exploited

CISA name
Craft CMS Code Injection Vulnerability
Required action
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Due for US agencies
3 Apr 2026
Used in ransomware
Not known

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2025-32432
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2025-32432