Servers and applications
CVE-2025-27446
Incorrect Permission Assignment for Critical Resource vulnerability in Apache APISIX(java-plugin-runner). Local listening file permissions in APISIX plugin runner allow a local attacker to elevate privileges. This issue affects Apache APISIX(java-plugin-runner): from 0.2.0 through 0.5.0. Users are recommended to upgrade to version 0.6.0 or higher, which fixes the issue.
- Severity
- High 7.8
- Published
- 6 Jul 2025
- Last changed
- 17 Jun 2026
- Added to UpHeron
- 1 Nov 2026
- Sources
- NVD
Affected software
| Software | Affected versions |
|---|---|
Apache APISIXServers and applications · cpe:a:apache:apisix |
|