All vulnerabilities

Servers and applications

CVE-2025-23209

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. This is an remote code execution (RCE) vulnerability that affects Craft 4 and 5 installs where your security key has already been compromised. Anyone running an unpatched version of Craft with a compromised security key is affected. This vulnerability has been patched in Craft 5.5.8 and 4.13.8.…

Actively exploited: CISA added it to its Known Exploited Vulnerabilities catalog on 20 Feb 2025.

Severity
High 8.1
Published
18 Jan 2025
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Fixed in
4.13.8, 5.5.8
Sources
NVD

Affected software

SoftwareAffected versions
Craft CMSServers and applications · cpe:a:craftcms:craft_cms
  • Version 5.0.0
  • After 5.0.0 before 5.5.8
  • Version 5.0.0-rc1
  • Version 4.0.0
All 8 release lines
  • Version 4.0.0-rc1
  • Version 4.0.0-rc2
  • Version 4.0.0-rc3
  • After 4.0.0 before 4.13.8
  • Version 4.0.0
  • Version 5.0.0-rc1
  • After 5.0.0 before 5.5.8
  • Version 5.0.0

Known exploited

CISA name
Craft CMS Code Injection Vulnerability
Required action
Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Due for US agencies
13 Mar 2025
Used in ransomware
Not known

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2025-23209
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2025-23209