All vulnerabilities

Servers and applications

CVE-2024-56145

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Users of affected versions are affected by this vulnerability if their php.ini configuration has `register_argc_argv` enabled. For these users an unspecified remote code execution vector is present. Users are advised to update to version 3.9.14, 4.13.2, or 5.5.2. Users unable to upgrade should…

Actively exploited: CISA added it to its Known Exploited Vulnerabilities catalog on 2 Jun 2025.

Severity
Critical 9.3
Published
18 Dec 2024
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Fixed in
3.9.14, 4.13.2, 5.5.2
Sources
NVD

Affected software

SoftwareAffected versions
Craft CMSServers and applications · cpe:a:craftcms:craft_cms
  • From 3.0.0 before 3.9.14
  • From 4.0.0 before 4.13.2
  • From 5.0.0 before 5.5.2

Known exploited

CISA name
Craft CMS Code Injection Vulnerability
Required action
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Due for US agencies
23 Jun 2025
Used in ransomware
Not known

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2024-56145
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2024-56145