All vulnerabilities

Servers and applications

CVE-2024-45398

Contao is an Open Source CMS. In affected versions a back end user with access to the file manager can upload malicious files and execute them on the server. Users are advised to update to Contao 4.13.49, 5.3.15 or 5.4.3. Users unable to update are advised to configure their web server so it does not execute PHP files and other scripts in the Contao file upload directory.

Severity
High 8.8
Published
17 Sept 2024
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Fixed in
4.13.49, 5.3.15, 5.4.3
Sources
NVD

Affected software

SoftwareAffected versions
ContaoServers and applications · cpe:a:contao:contao
  • From 4.0.0 before 4.13.49
  • From 5.0.0 before 5.3.15
  • From 5.4.0 before 5.4.3

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2024-45398
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2024-45398