Servers and applications
CVE-2024-39877
Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.
- Severity
- High 8.8
- Published
- 17 Jul 2024
- Last changed
- 17 Jun 2026
- Added to UpHeron
- 1 Nov 2026
- Fixed in
- 2.9.3
- Sources
- NVD
Affected software
| Software | Affected versions |
|---|---|
Apache AirflowServers and applications · cpe:a:apache:airflow |
|