All vulnerabilities

Servers and applications

CVE-2024-32638

Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in Apache APISIX when using `forward-auth` plugin.This issue affects Apache APISIX: from 3.8.0, 3.9.0. Users are recommended to upgrade to version 3.8.1, 3.9.1 or higher, which fixes the issue.

Severity
Medium 6.3
Published
2 May 2024
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Sources
NVD

Affected software

SoftwareAffected versions
Apache APISIXServers and applications · cpe:a:apache:apisix
  • Version 3.8.0
  • Version 3.9.0

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2024-32638
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2024-32638