Servers and applications
CVE-2024-28746
Apache Airflow, versions 2.8.0 through 2.8.2, has a vulnerability that allows an authenticated user with limited permissions to access resources such as variables, connections, etc from the UI which they do not have permission to access. Users of Apache Airflow are recommended to upgrade to version 2.8.3 or newer to mitigate the risk associated with this vulnerability
- Severity
- High 8.1
- Published
- 14 Mar 2024
- Last changed
- 17 Jun 2026
- Added to UpHeron
- 1 Nov 2026
- Fixed in
- 2.8.3
- Sources
- NVD
Affected software
| Software | Affected versions |
|---|---|
Apache AirflowServers and applications · cpe:a:apache:airflow |
|