Servers and applications
CVE-2024-2660
Vault and Vault Enterprise TLS certificates auth method did not correctly validate OCSP responses when one or more OCSP sources were configured. This vulnerability, CVE-2024-2660, affects Vault and Vault Enterprise 1.14.0 and above, and is fixed in Vault 1.16.0 and Vault Enterprise 1.16.1, 1.15.7, and 1.14.11.
- Severity
- Medium 6.8
- Published
- 4 Apr 2024
- Last changed
- 17 Jun 2026
- Added to UpHeron
- 1 Nov 2026
- Fixed in
- 1.14.11, 1.15.7, 1.16.0
- Sources
- NVD
Affected software
| Software | Affected versions |
|---|---|
HashiCorp VaultServers and applications · cpe:a:hashicorp:vault |
|