All vulnerabilities

Servers and applications

CVE-2024-25111

Squid is a web proxy cache. Starting in version 3.5.27 and prior to version 6.8, Squid may be vulnerable to a Denial of Service attack against HTTP Chunked decoder due to an uncontrolled recursion bug. This problem allows a remote attacker to cause Denial of Service when sending a crafted, chunked, encoded HTTP Message. This bug is fixed in Squid version 6.8. In addition, patches addressing this…

Severity
High 7.5
Published
6 Mar 2024
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Fixed in
6.8
Sources
NVD

Affected software

SoftwareAffected versions
SquidServers and applications · cpe:a:squid-cache:squid
  • From 3.5.27 before 6.8

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2024-25111
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2024-25111