All vulnerabilities

Servers and applications

CVE-2024-24773

Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1, which fixes the issue.

Severity
Medium 6.5
Published
28 Feb 2024
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Fixed in
3.0.4, 3.1.1
Sources
NVD

Affected software

SoftwareAffected versions
Apache SupersetServers and applications · cpe:a:apache:superset
  • Every version before 3.0.4
  • From 3.1.0 before 3.1.1

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2024-24773
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2024-24773