Servers and applications
CVE-2024-24772
A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
- Severity
- Medium 4.3
- Published
- 28 Feb 2024
- Last changed
- 17 Jun 2026
- Added to UpHeron
- 1 Nov 2026
- Fixed in
- 3.0.4, 3.1.1
- Sources
- NVD
Affected software
| Software | Affected versions |
|---|---|
Apache SupersetServers and applications · cpe:a:apache:superset |
|