Servers and applications
CVE-2023-49920
Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website opened in the same browser - by the user who also had Airflow UI opened - to trigger the execution of DAGs without the user's consent. Users are advised to upgrade to version 2.8.0 or later which…
- Severity
- Medium 6.5
- Published
- 21 Dec 2023
- Last changed
- 17 Jun 2026
- Added to UpHeron
- 1 Nov 2026
- Sources
- NVD
Affected software
| Software | Affected versions |
|---|---|
Apache AirflowServers and applications · cpe:a:apache:airflow |
|