All vulnerabilities

Servers and applications

CVE-2023-49736

A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache Superset: before 2.1.2, from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 3.0.2, which fixes the issue.

Severity
High 8.8
Published
19 Dec 2023
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Fixed in
2.1.2, 3.0.2
Sources
NVD

Affected software

SoftwareAffected versions
Apache SupersetServers and applications · cpe:a:apache:superset
  • Every version before 2.1.2
  • From 3.0.0 before 3.0.2

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2023-49736
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2023-49736