All vulnerabilities

Servers and applications

CVE-2023-42501

Unnecessary read permissions within the Gamma role would allow authenticated users to read configured CSS templates and annotations. This issue affects Apache Superset: before 2.1.2. Users should upgrade to version or above 2.1.2 and run `superset init` to reconstruct the Gamma role or remove `can_read` permission from the mentioned resources.

Severity
Medium 4.3
Published
27 Nov 2023
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Fixed in
2.1.1
Sources
NVD

Affected software

SoftwareAffected versions
Apache SupersetServers and applications · cpe:a:apache:superset
  • Every version before 2.1.1

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2023-42501
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2023-42501