Servers and applications
CVE-2023-40611
Apache Airflow, versions before 2.7.1, is affected by a vulnerability that allows authenticated and DAG-view authorized Users to modify some DAG run detail values when submitting notes. This could have them alter details such as configuration parameters, start date, etc. Users should upgrade to version 2.7.1 or later which has removed the vulnerability.
- Severity
- Medium 4.3
- Published
- 12 Sept 2023
- Last changed
- 17 Jun 2026
- Added to UpHeron
- 1 Nov 2026
- Fixed in
- 2.7.3
- Sources
- NVD
Affected software
| Software | Affected versions |
|---|---|
Apache AirflowServers and applications · cpe:a:apache:airflow |
|