All vulnerabilities

Servers and applications

CVE-2023-29489

An issue was discovered in cPanel before 11.109.9999.116. XSS can occur on the cpsrvd error page via an invalid webcall ID, aka SEC-669. The fixed versions are 11.109.9999.116, 11.108.0.13, 11.106.0.18, and 11.102.0.31.

Severity
Medium 6.1
Published
27 Apr 2023
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Fixed in
11.102.0.31, 11.106.0.18, 11.108.0.13, 11.109.9999.116
Sources
NVD

Affected software

SoftwareAffected versions
cPanel & WHMServers and applications · cpe:a:cpanel:cpanel
  • Every version before 11.102.0.31
  • From 11.104.0 before 11.106.0.18
  • From 11.108.0 before 11.108.0.13
  • From 11.109.0 before 11.109.9999.116

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2023-29489
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2023-29489