All vulnerabilities

Servers and applications

CVE-2023-27491

Envoy forwards invalid HTTP/2 and HTTP/3 downstream headers

Severity
Critical 9.1
Published
4 Apr 2023
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Fixed in
1.22.9, 1.23.6, 1.24.4, 1.25.3
Also known as
GHSA-5jmv-cw9p-f9rp
Sources
NVD, Project advisories (GitHub)

Description

Envoy is an open source edge and service proxy designed for cloud-native applications. Compliant HTTP/1 service should reject malformed request lines. Prior to versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9, There is a possibility that non compliant HTTP/1 service may allow malformed requests, potentially leading to a bypass of security policies. This issue is fixed in versions 1.26.0,…

Affected software

SoftwareAffected versions
EnvoyServers and applications · cpe:a:envoyproxy:envoy
  • Every version before 1.22.9
  • From 1.23.0 before 1.23.6
  • From 1.24.0 before 1.24.4
  • From 1.25.0 before 1.25.3
EnvoyServers and applications · github:envoyproxy/envoy
  • Every version before 1.22.9

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2023-27491
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2023-27491
  • GitHub Advisory Database https://github.com/advisories/GHSA-5jmv-cw9p-f9rp
  • github.com https://github.com/envoyproxy/envoy/security/advisories/GHSA-5jmv-cw9p-f9rp