All vulnerabilities

Servers and applications

CVE-2022-41556

A resource leak in gw_backend.c in lighttpd 1.4.56 through 1.4.66 could lead to a denial of service (connection-slot exhaustion) after a large amount of anomalous TCP behavior by clients. It is related to RDHUP mishandling in certain HTTP/1.1 chunked situations. Use of mod_fastcgi is, for example, affected. This is fixed in 1.4.67.

Severity
High 7.5
Published
6 Oct 2022
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Fixed in
1.4.67
Sources
NVD

Affected software

SoftwareAffected versions
lighttpdServers and applications · cpe:a:lighttpd:lighttpd
  • From 1.4.56 before 1.4.67

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2022-41556
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2022-41556