All vulnerabilities

Servers and applications

CVE-2022-41318

SQUID-2022:2 Buffer Over Read in SSPI and SMB Authentication

Severity
High 8.6
Published
23 Sept 2022
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Fixed in
5.7
Also known as
GHSA-394c-rr7q-6g78
Sources
NVD, Project advisories (GitHub)

Description

A buffer over-read was discovered in libntlmauth in Squid 2.5 through 5.6. Due to incorrect integer-overflow protection, the SSPI and SMB authentication helpers are vulnerable to reading unintended memory locations. In some configurations, cleartext credentials from these locations are sent to a client. This is fixed in 5.7.

Affected software

SoftwareAffected versions
SquidServers and applications · cpe:a:squid-cache:squid
  • From 2.5 before 5.7
SquidServers and applications · github:squid-cache/squid
  • From 2.5 before 5.7

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2022-41318
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2022-41318
  • GitHub Advisory Database https://github.com/advisories/GHSA-394c-rr7q-6g78
  • github.com https://github.com/squid-cache/squid/security/advisories/GHSA-394c-rr7q-6g78