All vulnerabilities

Servers and applications

CVE-2022-39313

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Versions prior to 4.10.17, and prior to 5.2.8 on the 5.x branch, crash when a file download request is received with an invalid byte range, resulting in a Denial of Service. This issue has been patched in versions 4.10.17, and 5.2.8. There are no known workarounds.

Severity
High 7.5
Published
24 Oct 2022
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Fixed in
4.10.17, 5.2.8
Sources
NVD

Affected software

SoftwareAffected versions
Parse ServerServers and applications · cpe:a:parseplatform:parse-server
  • Every version before 4.10.17
  • From 5.0.0 before 5.2.8

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2022-39313
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2022-39313