Servers and applications
CVE-2022-36129
HashiCorp Vault Enterprise 1.7.0 through 1.9.7, 1.10.4, and 1.11.0 clusters using Integrated Storage expose an unauthenticated API endpoint that could be abused to override the voter status of a node within a Vault HA cluster, introducing potential for future data loss or catastrophic failure. Fixed in Vault Enterprise 1.9.8, 1.10.5, and 1.11.1.
- Severity
- Critical 9.1
- Published
- 26 Jul 2022
- Last changed
- 17 Jun 2026
- Added to UpHeron
- 1 Nov 2026
- Sources
- NVD
Affected software
| Software | Affected versions |
|---|---|
HashiCorp VaultServers and applications · cpe:a:hashicorp:vault |
|