All vulnerabilities

Servers and applications

CVE-2022-36108

Cross-Site Scripting in <f:asset.css> view helper

Severity
Medium 6.1
Published
13 Sept 2022
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Fixed in
11.5.16
Also known as
GHSA-fv2m-9249-qx85
Sources
NVD, Project advisories (GitHub)

Description

TYPO3 is an open source PHP based web content management system released under the GNU GPL. It has been discovered that the `f:asset.css` view helper is vulnerable to cross-site scripting when user input is passed as variables to the CSS. Update to TYPO3 version 10.4.32 or 11.5.16 that fix the problem. There are no known workarounds for this issue.

Affected software

SoftwareAffected versions
TYPO3Servers and applications · cpe:a:typo3:typo3
  • From 10.0.0 up to 10.4.31
  • From 11.0.0 up to 11.5.15
TYPO3Servers and applications · github:typo3/typo3
  • From 11.0.0 before 11.5.16

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2022-36108
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2022-36108
  • GitHub Advisory Database https://github.com/advisories/GHSA-fv2m-9249-qx85
  • github.com https://github.com/TYPO3/typo3/security/advisories/GHSA-fv2m-9249-qx85