Servers and applications
CVE-2022-31181
Chain: SQL Injection (CWE-89) and Eval Injection (CWE-95)
- Severity
- Critical 9.8
- Published
- 25 Jul 2022
- Last changed
- 17 Jun 2026
- Added to UpHeron
- 1 Nov 2026
- Fixed in
- 1.7.8.7
- Also known as
- GHSA-hrgx-p36p-89q4
- Sources
- NVD, Project advisories (GitHub)
Description
PrestaShop is an Open Source e-commerce platform. In versions from 1.6.0.10 and before 1.7.8.7 PrestaShop is subject to an SQL injection vulnerability which can be chained to call PHP's Eval function on attacker input. The problem is fixed in version 1.7.8.7. Users are advised to upgrade. Users unable to upgrade may delete the MySQL Smarty cache feature.
Affected software
| Software | Affected versions |
|---|---|
PrestaShopServers and applications · cpe:a:prestashop:prestashop |
|
PrestaShopServers and applications · github:prestashop/prestashop |
|
References
- NVD https://nvd.nist.gov/vuln/detail/CVE-2022-31181
- CVE.org https://www.cve.org/CVERecord?id=CVE-2022-31181
- GitHub Advisory Database https://github.com/advisories/GHSA-hrgx-p36p-89q4
- github.com https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-hrgx-p36p-89q4