All vulnerabilities

Servers and applications

CVE-2022-31148

Shopware is an open source e-commerce software. In versions from 5.7.0 a persistent cross site scripting (XSS) vulnerability exists in the customer module. Users are recommend to update to the current version 5.7.14. You can get the update to 5.7.14 regularly via the Auto-Updater or directly via the download overview. There are no known workarounds for this issue.

Severity
Medium 5.4
Published
1 Aug 2022
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Fixed in
5.7.14
Sources
NVD

Affected software

SoftwareAffected versions
ShopwareServers and applications · cpe:a:shopware:shopware
  • From 5.7.0 before 5.7.14

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2022-31148
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2022-31148