All vulnerabilities

Servers and applications

CVE-2022-29158

Apache OFBiz up to version 18.12.05 is vulnerable to Regular Expression Denial of Service (ReDoS) in the way it handles URLs provided by external, unauthenticated users. Upgrade to 18.12.06 or apply patches at https://issues.apache.org/jira/browse/OFBIZ-12599

Severity
High 7.5
Published
2 Sept 2022
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Fixed in
18.12.06
Sources
NVD

Affected software

SoftwareAffected versions
Apache OFBizServers and applications · cpe:a:apache:ofbiz
  • Every version before 18.12.06

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2022-29158
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2022-29158