All vulnerabilities

Servers and applications

CVE-2022-24873

Shopware is an open source e-commerce software platform. Prior to version 5.7.9, Shopware is vulnerable to non-stored cross-site scripting in the storefront. This issue is fixed in version 5.7.9. Users of older versions may attempt to mitigate the vulnerability by using the Shopware security plugin.

Severity
Medium 6.1
Published
28 Apr 2022
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Fixed in
5.7.9
Sources
NVD

Affected software

SoftwareAffected versions
ShopwareServers and applications · cpe:a:shopware:shopware
  • From 5.0.0 before 5.7.9

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2022-24873
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2022-24873