All vulnerabilities

Servers and applications

CVE-2022-24871

Server-Side Request Forgery (SSRF) in Admin SDK

Severity
Medium 5.5
Published
20 Apr 2022
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Fixed in
6.4.10.1
Also known as
GHSA-7gm7-8q8v-9gf2
Sources
NVD, Project advisories (GitHub)

Description

Shopware is an open commerce platform based on Symfony Framework and Vue. In affected versions an attacker can abuse the Admin SDK functionality on the server to read or update internal resources. Users are advised to update to the current version 6.4.10.1. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. There are no known workarounds for…

Affected software

SoftwareAffected versions
ShopwareServers and applications · cpe:a:shopware:shopware
  • Every version before 6.4.10.1
ShopwareServers and applications · github:shopware/shopware
  • Every version before 6.4.10.1

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2022-24871
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2022-24871
  • GitHub Advisory Database https://github.com/advisories/GHSA-7gm7-8q8v-9gf2
  • github.com https://github.com/shopware/shopware/security/advisories/GHSA-7gm7-8q8v-9gf2