All vulnerabilities

Servers and applications

CVE-2022-24783

Sandbox bypass leading to arbitrary code execution

Severity
Critical 10.0
Published
25 Mar 2022
Last changed
17 Jun 2026
Added to UpHeron
1 Nov 2026
Fixed in
1.20.3
Also known as
GHSA-838h-jqp6-cf2f
Sources
NVD, Project advisories (GitHub)

Description

Deno is a runtime for JavaScript and TypeScript. The versions of Deno between release 1.18.0 and 1.20.2 (inclusive) are vulnerable to an attack where a malicious actor controlling the code executed in a Deno runtime could bypass all permission checks and execute arbitrary shell code. This vulnerability does not affect users of Deno Deploy. The vulnerability has been patched in Deno 1.20.3. There…

Affected software

SoftwareAffected versions
DenoServers and applications · cpe:a:deno:deno
  • From 1.18.0 before 1.20.3
DenoServers and applications · github:denoland/deno
  • From 1.18.0 before 1.20.3

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2022-24783
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2022-24783
  • GitHub Advisory Database https://github.com/advisories/GHSA-838h-jqp6-cf2f
  • github.com https://github.com/denoland/deno/security/advisories/GHSA-838h-jqp6-cf2f