All vulnerabilities

Servers and applications

CVE-2022-23641

Discourse is an open source discussion platform. In versions prior to 2.8.1 in the `stable` branch, 2.9.0.beta2 in the `beta` branch, and 2.9.0.beta2 in the `tests-passed` branch, users can trigger a Denial of Service attack by posting a streaming URL. Parsing Oneboxes in the background job trigger an infinite loop, which cause memory leaks. This issue is patched in version 2.8.1 of the `stable`…

Severity
Medium 6.5
Published
15 Feb 2022
Last changed
17 Jun 2026
Added to UpHeron
21 Oct 2026
Fixed in
2.8.1
Sources
NVD

Affected software

SoftwareAffected versions
DiscourseServers and applications · cpe:a:discourse:discourse
  • Every version before 2.8.1

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2022-23641
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2022-23641