All vulnerabilities

WordPress core

CVE-2022-21663

WordPress: Authenticated Object Injection in Multisites

Severity
High 7.2
Published
6 Jan 2022
Last changed
17 Jun 2026
Added to UpHeron
17 Oct 2026
Fixed in
5.8.3
Also known as
GHSA-jmmq-m8p8-332h
Sources
NVD, WordPress

Description

WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. On a multisite, users with Super Admin role can bypass explicit/additional hardening under certain conditions through object injection. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 3.7.37. We strongly…

Affected software

SoftwareAffected versions
WordPressWordPress core · cpe:a:wordpress:wordpress
  • Every version before 5.8.3

References