All vulnerabilities

Servers and applications

CVE-2021-37633

Discourse is an open source discussion platform. In versions prior to 2.7.8 rendering of d-popover tooltips can be susceptible to XSS attacks. This vulnerability only affects sites which have modified or disabled Discourse's default Content Security Policy. This issue is patched in the latest `stable` 2.7.8 version of Discourse. As a workaround users may ensure that the Content Security Policy…

Severity
Medium 6.1
Published
9 Aug 2021
Last changed
17 Jun 2026
Added to UpHeron
21 Oct 2026
Fixed in
2.7.8
Sources
NVD

Affected software

SoftwareAffected versions
DiscourseServers and applications · cpe:a:discourse:discourse
  • Every version before 2.7.8
  • Version 2.8.0-beta2
  • Version 2.8.0-beta3

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2021-37633
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2021-37633