All vulnerabilities

Servers and applications

CVE-2021-32800

Nextcloud server is an open source, self hosted personal cloud. In affected versions an attacker is able to bypass Two Factor Authentication in Nextcloud. Thus knowledge of a password, or access to a WebAuthN trusted device of a user was sufficient to gain access to an account. It is recommended that the Nextcloud Server is upgraded to 20.0.12, 21.0.4 or 22.1.0. There are no workaround for this…

Severity
High 8.1
Published
7 Sept 2021
Last changed
17 Jun 2026
Added to UpHeron
21 Oct 2026
Fixed in
20.0.12, 21.0.4, 22.1.0
Sources
NVD

Affected software

SoftwareAffected versions
NextcloudServers and applications · cpe:a:nextcloud:nextcloud_server
  • Every version before 20.0.12
  • From 21.0.0 before 21.0.4
  • From 22.0.0 before 22.1.0

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2021-32800
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2021-32800