All vulnerabilities

Servers and applications

CVE-2021-32764

Discourse is an open-source discussion platform. In Discourse versions 2.7.5 and prior, parsing and rendering of YouTube Oneboxes can be susceptible to XSS attacks. This vulnerability only affects sites which have modified or disabled Discourse's default Content Security Policy. The issue is patched in `stable` version 2.7.6, `beta` version 2.8.0.beta3, and `tests-passed` version 2.8.0.beta3. As…

Severity
Medium 5.4
Published
15 Jul 2021
Last changed
17 Jun 2026
Added to UpHeron
21 Oct 2026
Sources
NVD

Affected software

SoftwareAffected versions
DiscourseServers and applications · cpe:a:discourse:discourse
  • Every version up to 2.7.5
  • Version 2.8.0-beta1

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2021-32764
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2021-32764