All vulnerabilities

WordPress core

CVE-2021-29450

WordPress: Authenticated disclosure of password-protected posts and pages

Severity
Medium 4.3
Published
15 Apr 2021
Last changed
17 Jun 2026
Added to UpHeron
17 Oct 2026
Fixed in
5.7.1
Also known as
GHSA-pmmh-2f36-wvhq
Sources
NVD, WordPress

Description

Wordpress is an open source CMS. One of the blocks in the WordPress editor can be exploited in a way that exposes password-protected posts and pages. This requires at least contributor privileges. This has been patched in WordPress 5.7.1, along with the older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.

Affected software

SoftwareAffected versions
WordPressWordPress core · cpe:a:wordpress:wordpress
  • From 4.7 before 5.7.1

References