All vulnerabilities

WordPress core

CVE-2021-29447

WordPress: Authenticated XXE attack when installation is running PHP 8

Severity
Medium 6.5
Published
15 Apr 2021
Last changed
17 Jun 2026
Added to UpHeron
17 Oct 2026
Fixed in
5.7.1
Also known as
GHSA-rv47-pc52-qrhh
Sources
NVD, WordPress

Description

Wordpress is an open source CMS. A user with the ability to upload files (like an Author) can exploit an XML parsing issue in the Media Library leading to XXE attacks. This requires WordPress installation to be using PHP 8. Access to internal files is possible in a successful XXE attack. This has been patched in WordPress version 5.7.1, along with the older affected versions via a minor release.…

Affected software

SoftwareAffected versions
WordPressWordPress core · cpe:a:wordpress:wordpress
  • From 5.6.0 before 5.7.1

References