All vulnerabilities

WordPress core

CVE-2020-11030

Cross-site scripting (XSS) in Search block - WordPress

Severity
Medium 5.4
Published
30 Apr 2020
Last changed
17 Jun 2026
Added to UpHeron
17 Oct 2026
Fixed in
5.4.1
Also known as
GHSA-vccm-6gmc-qhjh
Sources
NVD, WordPress

Description

In affected versions of WordPress, a special payload can be crafted that can lead to scripts getting executed within the search block of the block editor. This requires an authenticated user with the ability to add content. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18,…

Affected software

SoftwareAffected versions
WordPressWordPress core · cpe:a:wordpress:wordpress
  • Every version before 5.4.1
  • From 5.2 before 5.4.1

References