All vulnerabilities

WordPress core

CVE-2020-11028

WordPress: Unauthenticated disclosure of certain private posts

Severity
High 7.5
Published
30 Apr 2020
Last changed
17 Jun 2026
Added to UpHeron
17 Oct 2026
Fixed in
5.4.1
Also known as
GHSA-xhx9-759f-6p2w
Sources
NVD, WordPress

Description

In affected versions of WordPress, some private posts, which were previously public, can result in unauthenticated disclosure under a specific set of conditions. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33,…

Affected software

SoftwareAffected versions
WordPressWordPress core · cpe:a:wordpress:wordpress
  • Every version before 5.4.1
  • From 3.7 before 5.4.1

References