All vulnerabilities

Servers and applications

CVE-2019-7139

An unauthenticated user can execute SQL statements that allow arbitrary read access to the underlying database, which causes sensitive data leakage. This issue is fixed in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2.

Severity
Critical 9.8
Published
10 Apr 2019
Last changed
17 Jun 2026
Added to UpHeron
21 Oct 2026
Fixed in
1.9.4.1, 1.14.4.1, 2.1.17, 2.2.8, 2.3.1
Sources
NVD

Affected software

SoftwareAffected versions
Magento / Adobe CommerceServers and applications · cpe:a:magento:magento
  • Every version before 1.9.4.1
  • From 1.14.0.0 before 1.14.4.1
  • From 2.1.0 before 2.1.17
  • From 2.2.0 before 2.2.8
  • From 2.3.0 before 2.3.1

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2019-7139
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2019-7139