Servers and applications
CVE-2019-3396
The Widget Connector macro in Atlassian Confluence Server before version 6.6.12 (the fixed version for 6.6.x), from version 6.7.0 before 6.12.3 (the fixed version for 6.12.x), from version 6.13.0 before 6.13.3 (the fixed version for 6.13.x), and from version 6.14.0 before 6.14.2 (the fixed version for 6.14.x), allows remote attackers to achieve path traversal and remote code execution on a…
Actively exploited: CISA added it to its Known Exploited Vulnerabilities catalog on 3 Nov 2021.
- Severity
- Critical 9.8
- Published
- 25 Mar 2019
- Last changed
- 17 Jun 2026
- Added to UpHeron
- 21 Oct 2026
- Fixed in
- 6.6.12, 6.12.3, 6.13.3, 6.14.2
- Sources
- NVD
Affected software
| Software | Affected versions |
|---|---|
ConfluenceServers and applications · cpe:a:atlassian:confluence_server |
|
Known exploited
- CISA name
- Atlassian Confluence Server and Data Center Server-Side Template Injection Vulnerability
- Required action
- Apply updates per vendor instructions.
- Due for US agencies
- 3 May 2022
- Used in ransomware
- Yes, known