Servers and applications
CVE-2019-12472
An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
- Severity
- High 7.5
- Published
- 10 Jul 2019
- Last changed
- 17 Jun 2026
- Added to UpHeron
- 21 Oct 2026
- Fixed in
- 1.27.6, 1.30.2, 1.31.2, 1.32.2
- Sources
- NVD
Affected software
| Software | Affected versions |
|---|---|
MediaWikiServers and applications · cpe:a:mediawiki:mediawiki |
|