All vulnerabilities

Servers and applications

CVE-2019-12471

Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS. Loading user JavaScript from a non-existent account allows anyone to create the account, and perform XSS on users loading that script. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

Severity
Medium 6.1
Published
10 Jul 2019
Last changed
17 Jun 2026
Added to UpHeron
21 Oct 2026
Fixed in
1.30.2, 1.31.2, 1.32.2
Sources
NVD

Affected software

SoftwareAffected versions
MediaWikiServers and applications · cpe:a:mediawiki:mediawiki
  • From 1.30.0 before 1.30.2
  • From 1.31.0 before 1.31.2
  • From 1.32.0 before 1.32.2

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2019-12471
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2019-12471