All vulnerabilities

Servers and applications

CVE-2019-0197

A vulnerability was found in Apache HTTP Server 2.4.34 to 2.4.38. When HTTP/2 was enabled for a http: host or H2Upgrade was enabled for h2 on a https: host, an Upgrade request from http/1.1 to http/2 that was not the first request on a connection could lead to a misconfiguration and crash. Server that never enabled the h2 protocol or that only enabled it for https: and did not set "H2Upgrade on"…

Severity
Medium 4.2
Published
11 Jun 2019
Last changed
17 Jun 2026
Added to UpHeron
17 Oct 2026
Sources
NVD

Affected software

SoftwareAffected versions
Apache HTTP ServerServers and applications · cpe:a:apache:http_server
  • From 2.4.34 up to 2.4.38

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2019-0197
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2019-0197