All vulnerabilities

Servers and applications

CVE-2018-1000622

The Rust Programming Language rustdoc version Between 0.8 and 1.27.0 contains a CWE-427: Uncontrolled Search Path Element vulnerability in rustdoc plugins that can result in local code execution as a different user. This attack appear to be exploitable via using the --plugin flag without the --plugin-path flag. This vulnerability appears to have been fixed in 1.27.1.

Severity
High 7.8
Published
9 Jul 2018
Last changed
17 Jun 2026
Added to UpHeron
22 Oct 2026
Sources
NVD

Affected software

SoftwareAffected versions
RustServers and applications · cpe:a:rust-lang:rust
  • From 0.8 up to 1.27.0

References

  • NVD https://nvd.nist.gov/vuln/detail/CVE-2018-1000622
  • CVE.org https://www.cve.org/CVERecord?id=CVE-2018-1000622