Servers and applications
CVE-2018-1000301
curl version curl 7.20.0 to and including curl 7.59.0 contains a CWE-126: Buffer Over-read vulnerability in denial of service that can result in curl can be tricked into reading data beyond the end of a heap based buffer used to store downloaded RTSP content.. This vulnerability appears to have been fixed in curl < 7.20.0 and curl >= 7.60.0.
- Severity
- Critical 9.1
- Published
- 24 May 2018
- Last changed
- 17 Jun 2026
- Added to UpHeron
- 21 Oct 2026
- Sources
- NVD
Affected software
| Software | Affected versions |
|---|---|
curlServers and applications · cpe:a:haxx:curl |
|